Discussions

Ask a Question
Back to All

REST ContentItem error 20.3.136.136

Hello,

Developing REST logic which works in 2017 fine
/api/ContentItem?ContentKey=${contentKey}&ContentItemKey=${contentItemKey}`
this helps get "Settings" (entered in ipart configure)

In cloud (20.3.136.136) test of same logic get error
{$type: 'System.Web.Http.HttpError, System.Web.Http', Message: 'Authorization has been denied for this request.'}
(had a good bearer token - other API calls worked)
Looking at the documentation 20.3.135 appears API call has changed from 2017, which probably creating this error. Cloud uses only one parameter
https://yourorgsite.com/api/ContentItem/{ContentItemId}

Reviewed the SDK documentation and could not see how to get the ContentItemId.
also, while investigating tried this API to get a list of contentItems, but got 404 error?
https://demoaisp21.imiscloud.com/api/ContentItem
get 404 - Not found

ASI tech support has reported this as a defect - https://support.imis.com/hc/en-us/requests/236127

Is there example and/or information on how to get the configure settings in cloud (assuming "Returns a ContentItem by id"?). Need to run the ipart display page based on configure settings.

Thanks Nick

Start typing markdown or type / to insert a block