Discussions

Ask a Question

Register for an Event Someone Else

Hello! I'm trying to register and existing Contact using Rise, but I don't see the button that it should exist according to this document [https://docs.imis.com/20.2/Understanding_iMIS_Features/Events/Registering_for_events.htm?Highlight=register%20for%20events] and that would let me select another contact: I'm logged in as administrator, so I guess it's not a permission problem. Thank you
ANSWERED

IQA in REST with Filter in 105 doesn't filter using code that worked in .98

Post to https://{{URL}}/api/queryservice/_execute Body {     "$type":"Asi.Soa.Core.DataContracts.GenericExecuteRequest, Asi.Contracts",     "EntityTypeName":"QueryService",     "OperationName":"FindByPath",     "Parameters":{         "$type":"System.Collections.ObjectModel.Collection`1[[System.Object, mscorlib]], mscorlib",         "$values":[         {             "$type":"System.String",             "$value":"$/Common/Queries/Search/Contact/Last Name"         },         {             "$type":"Asi.Soa.Core.DataContracts.QueryData, Asi.Contracts",             "Criteria":{                 "$type":"Asi.Soa.Core.DataContracts.CriteriaDataCollection, Asi.Contracts",                 "$values":[{                     "$type": "Asi.Soa.Core.DataContracts.CriteriaDataCollection, Asi.Contracts",                     "Operation":3,                     "PropertyName":"LastName",                     "Values":["smith"]                 }]             }         }]    } } Query has optional filter and returns all values even after last name parameter is sent

REST API: IQA cached response

Hi, is there a header we can send in the REST GET request for the api/iqa endpoint? We have noticed, that even though the flag on the IQA "Use cached results" is NOT set, that query data is cached when received through the endpoint. Best, Alex

Executes a GenericExecuteRequest: ProcessOrderReversal

Hi, what is the structure of JSON object we need to add in place of "invoiceActionOrderReversalData Value"? Thanks much! Alex { "$type": "Asi.Soa.Core.DataContracts.GenericExecuteRequest, Asi.Contracts", "OperationName": "ProcessOrderReversal", "EntityTypeName": "Invoice", "Parameters": { "$type": "System.Collections.ObjectModel.Collection`1[[System.Object, mscorlib]], mscorlib", "$values": [ { "$type": "Asi.Soa.Commerce.DataContracts.InvoiceActionOrderReversalData", "$value": "invoiceActionOrderReversalData Value" } ] }, "ParameterTypeName": { "$type": "System.Collections.ObjectModel.Collection`1[[System.String, mscorlib]], mscorlib", "$values": [ "Asi.Soa.Commerce.DataContracts.InvoiceActionOrderReversalData" ] }, "UseJson": false }
ANSWERED

Cannot POST ComboOrder after validation success

Hi, Additional attachments can be found in this support thread: https://support.imis.com/hc/en-us/requests/192867 I'm trying to make a minimal POST body stub I can use to work with modifying events. To that end I've POSTed (stub.json in the attached support ticket) to /api/ComboOrder/_validate. I received no validation errors or warnings, and received the validateResults.json in the attached ticket. I then tried POSTing the "Entity" property returned in the "validationResults.json" to /api/ComboOrder, however I then receive the following error: https://imis.zendesk.com/attachments/token/UN9FaPNx75kVHEMRyV2nqXfyg/?name=POSTresponse-400validationerror.json Why is this happening? Shouldn't the object returned from the /validate call work just fine since it's validated? Thank you
ANSWERED

Support for .NET Core 3.1

According to https://developer.imis.com/v1.0.1/docs/using-the-client-library-asisoaclientservices, “access to iMIS SOA web services for most .NET programmers is through a client library.” We are writing a .NET Core 3.1 application that will consume service iMIS SOA web service v1.0.1 (for iMIS 2017). Do you have a version of Asi.Soa.ClientServices library that can be used in a .NET core application?

Event Registration using REST API - IMIS2017

Hello, I've heard from ASI that the Event Registration using REST API is a missing function in the IMIS2017 REST API, but I still need to accomplish this task of registering for an Event. And it needs to be cloud friendly, which means that the code that I’ll be building for our current Imis version (the IMIS2017) needs to be cloud friendly. What is the option I have, or better, what are the options ? I didn't find any example or documentation on how to do this. Thank you !

iMIS Cloud - File Importer

Is the documentation at https://developer.imis.com/docs/custom-importer-replacing-the-file-importer#example-replacing-the-file-importer still the best cloud friendly solution to importing orders and other data into iMIS? If so, where do the project files exist? I searched the GitHub repositories but did not see a repository for this.
ANSWERED

Updating records in mass for erasure

Is there a way to mark records for erasure without updating them one by one?

Bad Request when Creating an Event Registration

I am attempting to use this endpoint, https://{{URL}}/api/EventRegistration/_execute, in Postman to create a new event registration. Here is the body of my request. { "$type": "Asi.Soa.Events.DataContracts.EventRegistrationRequest, Asi.Contracts", "EntityTypeName": "EventRegistration", "OperationName": "RegisterEvent", "RegistrationType": { "$type": "Asi.Soa.Events.DataContracts.EventRegistrationType, Asi.Contracts", "RegistrationType": 3 }, "EventId": "21CONVENT", "RegistrationOptionFunctionId": "21CONVENT/RO1", "FunctionId": "21CONVENT/TEST", "RegistrantId": "80856", "RegisteredBy": "80856", "BillTo": "102", "Waitlist": false } Each time, I get a status of 400 Bad Request. Any thoughts on what might be off here. Thanks, Korey
ANSWERED

Disable "add a contact" to a company roster

Hello! We are a trade association and our members are companies that include their employees. We are having trouble with members adding new contacts when they are registering for someone else and we'd like to disable this option as it's causing duplicate records in our system. Has anyone else had this issue and figured out a way to prevent this?
ANSWERED

Update Order_Badge using rest API

Can any one let me know how i can update Order_Badge Table using Rest API in cloud? I am also facing issue in Creating New Activity Type using Rest API in cloud.
ANSWERED

Documentation about Invoice Type

Hello, In this article: [Adding, modifying and paying for a subscription](https://developer.imis.com/docs/adding-modifying-and-paying-for-a-subscription) It is mentioned to find InvoiceSummary record using the filter: InvoiceType=SubscriptionFees It appears there are more than one possible value for InvoiceType? * SubscriptionFees * MembershipRenewal * MembershipJoin * MembershipAdjustment * PastDueMembershipRenewal Where could we learn more about those?
ANSWERED

Validate active membership status for email address

I'll have an email address from which I believe I can look up the party using an email address as per https://developer.imis.com/reference/find-party-using-filter-operator. E.g. /api/party?email=eq:[email protected] I've looked at https://testapi.imis.com/swagger/?url=https://testapi.imis.com/swagger/Enterprise/party.json and https://testapi.imis.com/swagger/Enterprise/party.json but I'm unclear on what I need to actually determine if the party's membership status is active. Is the best method to take the returned _Party_ object, and check if the property _PartyData.Status.ActiveStatus_ enum equals `"Active"`? Thanks for your help!
ANSWERED

What is /api/GenTable/GenTableId - "GenTableId"

I would have thought it would be the "tablename", however that doesn't appear to be the case. So what is this "GenTableId" URL param of the "/api/GenTable/GenTableId" endpoint? https://developer.imis.com/reference/gentable#getgentablebyid When you GET /api/GenTable/ to get a list, none of the results contain anything that looks like an Id. So I'm not sure how you're supposed to use this endpoint with the other operations like PUT. Thank you

Look up purchase for specific party?

I'm new to iMIS and have been reading to find out how to look up a purchase for a specific party. I'll have an email address from which I believe I can look up the party using an email address as per https://developer.imis.com/reference/find-party-using-filter-operator. E.g. api/party?email=eq:[email protected] Then once I have the party ID I want to see if that party made a specific purchase. I expect I'd be using the api/Invoice endpoint as per https://developer.imis.com/reference/invoice#getinvoice but I don't see how I can filter by the party I'd previously looked up. I only want invoices from a single party.

Test REST API?

I'm completely unfamiliar with iMIS and have been reading over the documentation and other questions here. To get an understanding on the REST API, I'd like to make some calls via Postman. From the discussion at https://developer.imis.com/discuss/5cf83ceda1dde9001f1af82c it seems like the following HTTP request would get a new token from the test API: -------- POST /Asi.Scheduler_SDKDemo/Token HTTP/1.1 Host: testapicloud.imis.com Content-Type: application/x-www-form-urlencoded Content-Length: 54 username=demouser&password=demo123&grant_type=password -------- However, this returns a 500 Internal Server Error with the message "Server Error in '/' Application." Note that I am a third party working with an iMIS customer to pull data from iMIS, so I have no credentials at this point.
ANSWERED

Forms authentication cookies

I have successfully set up SSO between a .NET site and a RiSE iMIS site, using Forms Authentication cookies. ie. Using different subdomains of the same parent domain and ensuring both sites have the same machine key. www.domain.com (website) portal.domain.com (imis) The iMIS Membership service method LoginUserAndProvideCookies() is called to get the cookies and these are set for *.domain.com This all works fine. The user is logged into iMIS by setting those cookies. However, if the user clicks the Sign out link in the iMIS portal, they aren't signed out of iMIS. From my testing I can see an iMIS logout will delete the portal.domain.com "Login" cookie, but won't delete the *.domain.com "Login" cookie. Any ideas what could be causing this?
ANSWERED

/api/Item - Financial Entity always shows blank for Dues products

Hello, We have multiple financial entities. Some Commerce and some Dues products have different entities. However the Entity reported in the /api/Item/<item id> endpoint always returns blank for Dues products. The UI shows the correct entity in Membership -> Billing Products -> <Dues Product> -> Accounting - Financial entity Is this a bug? Or am I supposed to use another endpoint to get the actual financial entity of a membership product? Example output of Commerce Item: ``` "ItemFinancialInformation": { "$type": "Asi.Soa.Commerce.DataContracts.ItemFinancialInformationData, Asi.Contracts", "FinancialEntity": { "$type": "Asi.Soa.Commerce.DataContracts.FinancialEntityData, Asi.Contracts", "EntityCode": "AAUS" }, ``` Example output of Dues Item: ``` "ItemFinancialInformation": { "$type": "Asi.Soa.Commerce.DataContracts.ItemFinancialInformationData, Asi.Contracts", "FinancialEntity": { "$type": "Asi.Soa.Commerce.DataContracts.FinancialEntityData, Asi.Contracts" }, ``` Thanks.
ANSWERED

Changes impacting upload member photo

Uploading a member photo recently become unavailable on our site. investigations uncovered the following: On page https://mentorsforwomen.app/account clicking the edit profile button adds a faded backdrop '<div class="modal-backdrop fade in"></div>' and makes visible the modal (pop out window) id ctl01_TemplateBody_WebPartManager1_gwpciProfileimage_ciProfileimage_contactPicture_profilePictureEditModal by changing the style="display: none;" to style="display: block;" and adding the css class 'in' which triggers the css .fade.in { opacity: 1; } in the imis css file at https://mentorsforwomen.app/Assets/css/10-UltraWaveResponsive.css. When the bootstrap css styling script 'https://stackpath.bootstrapcdn.com/bootstrap/4.3.1/css/bootstrap.min.css' we are using to style the app is active for the site the faded backdrop '<div class="modal-backdrop fade in"></div>' is generated and the 'in' class added but our css overrides the code in 10-UltraWaveResponsive.css The problem seems to arise because the core iMis solution does not appear to have used a naming convention different from Bootstrap. It would be helpful to know what has changed in the last release that caused this issue, and how we can ensure we don't have further issues like this.